Повторяющиеся логины пользователей

Публикация № 1179080

Администрирование - Информационная безопасность - Роли и права

5
В этой статье хочу предложить для рассмотрения небольшую но полезную обработку, которая работает в режиме внешней обработки и выявляет задвоенные логины пользователей. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854.

Задача возникла в результате того, что я работаю в специфической организации,
где часто идет ротация пользователей(
например аудиторы заходят или фискалы, за раз до 50-60 пользователей). В результате довольно
частая ситуация появляются в базе пользователи с одинаковыми логинами и их надо отлавливать периодически.
Эта обработка дает возможность это делать, плюс парочка дополнительных
возможностей, просмотр всех пользователей и просмотр работающих пользователей. Обработка используется на практике. 

 

Представляю скриншоты которые показывают три закладки на форме обработки:

 

1. Отображены все пользователи

2. Отображены двойные логины

3. Отображены работающие пользователи

Программа запускается как внешняя обработка:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

		ОбработкаСписка();

КонецПроцедуры

    На форме обработки имеется кнопка "Инструкция", которая запускает процедуру ИнструкцияПоЭксплуатации(Команда):

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации     
    Инструкция="          Инструкция на обработку двойной логин."+Символы.ПС+" 
    |1. На закладке ""Все пользователи"" отображаются все пользователи базы."+Символы.ПС+"
    |2. На закладке ""Двойные логины"" отображаются пользователи с повторяющимися логинами (выбираются только действующие пользователи)."+Символы.ПС+"
    |3. На закладке ""Список рабочих пользователей"" отображаются только действующие пользователи";
    
    Предупреждение(Инструкция);
    
КонецПроцедуры

    Следующая процедура заполняет три закладки, которые указаны выше на скриншотах.
Подробно работа процедуры описана в комментариях.

&НаСервере
Процедура ОбработкаСписка()
		ТаблицаСписокПользователей.Очистить();
		ТаблицаДействующихПользователей.Очистить();
		ПорядковыйНомер=0;
		
		//Создаем Массив пользователей Информационной Базы для изменения доменов *****************************
		Выборка= ПользователиИнформационнойБазы.ПолучитьПользователей();                           //Получаем массив пользователей и  из массива выбираем нужного пользователя по идентификатору
		Для Каждого ЭлементМассива Из Выборка Цикл
			ПолноеИмяПользователя=ЭлементМассива.ПолноеИмя;                                        //Из массива забираем полное имя пользователя
			ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор;             //Из массива забираем уникальный идентификатор пользователя
			ДоменЛогин=ЭлементМассива.ПользовательОС;                                              //Из Массива забираем домен логин пользователя
			
			Запрос = Новый Запрос;                                                                 //Определяем текущего пользователя в справочнике Пользователи 
			Запрос.Текст = 
			"ВЫБРАТЬ
			|	Пользователи.Наименование КАК Наименование,
			|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
			|ИЗ
			|	Справочник.Пользователи КАК Пользователи
			|ГДЕ
			|	Пользователи.ИдентификаторПользователяИБ = &ПользовательУникльныйИдентификатор"
			;
			Запрос.УстановитьПараметр("ПользовательУникльныйИдентификатор",ПользовательУникльныйИдентификатор);
			РезультатЗапроса = Запрос.Выполнить();
			Выборка = РезультатЗапроса.Выбрать();                                
			Пока Выборка.Следующий() Цикл
				Если Выборка.ПометкаУдаления=Ложь Тогда
					ПометкаУдаленияПользователя = "Действует";                                       //Записываем результат ПометкаУдаления
				Иначе
					ПометкаУдаленияПользователя = "Удален";
				КонецЕсли;		
			КонецЦикла; 
			
			//****************************************************************************************************				  
			Если НЕ	ДоменЛогин="" Тогда		                                                         //Выделяем из ДоменЛогин Домен и логин
				ДлинаДомена=СтрДлина(ДоменЛогин);
				ДоменПользователя="";
				ЛогинПользователя="";
				Буква="";
				СчетчикБукв=3;
				Буква=Сред(ДоменЛогин,СчетчикБукв,1);
				ФлагДЛ="Д";
				Пока СчетчикБукв <= ДлинаДомена Цикл
					Если Буква="\" Тогда
						ФлагДЛ="Л";
						СчетчикБукв=СчетчикБукв+1;
						Буква=Сред(ДоменЛогин,СчетчикБукв,1);
					Иначе
						Если ФлагДЛ="Д" Тогда
							ДоменПользователя=ДоменПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
						Если ФлагДЛ="Л" Тогда
							ЛогинПользователя=ЛогинПользователя+Буква; 
							СчетчикБукв=СчетчикБукв+1;
							Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
						КонецЕсли;
					КонецЕсли;
				КонецЦикла;
			Иначе
				ЛогинПользователя="";
				ДоменПользователя="";
			КонецЕсли;
//***************************************************************************************************************************************************
//Заносим в таблицу всех пользователей по списку*****************************************************************************************************
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=СокрЛП(ДоменЛогин);
			Строка.ДоменПользователя =СокрЛП(ДоменПользователя) ;
			Строка.ЛогинПользователя =СокрЛП(ЛогинПользователя) ;
			Строка.ПометкаУдаления=ПометкаУдаленияПользователя;
		КонецЦикла;
		ПорядковыйНомер=0;
		Запрос = Новый Запрос;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
//Помещаем таблицу пользователей во временную таблицу и из нее выбираем талько рабочих пользователей, помещаем их в таблицу рабочих пользователей****	
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя,
		|	ТСП1.ПометкаУдаления КАК ПометкаУдаления
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	Пользователи.Ссылка КАК ПользовательСсылка,
		|	Пользователи.ПометкаУдаления КАК ПометкаУдаления
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = Истина
		|
		|УПОРЯДОЧИТЬ ПО
		|	ПолноеИмяПользователя"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                                                 //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаСписокРабочихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ПометкаУдаления =Выборка.ПометкаУдаления ;
		КонецЦикла;
		
//Помещаем таблицу рабочих пользователей во временную таблицу, выбираем пользователей со сдвоенными логинами для этого используем "КОЛИЧЕСТВО"*******
//и одно поле группировки во временную таблицу  СдвоенныеЗаписи . Соединяем временные таблицы и справочник Пользователи******************************
		ПорядковыйНомер=0;
		ЛогинКоличество1=1;
		ТСП = РеквизитФормыВЗначение("ТаблицаСписокПользователей",Тип("ТаблицаЗначений"));           //Выгружаем Табличный реквизит формы в переменную
		МВТ=Новый МенеджерВременныхТаблиц;                                                           //Создаем МенеджерВременныхТаблиц
		Запрос.МенеджерВременныхТаблиц=МВТ;
		
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ТСП1.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ТСП1.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ТСП1.ДоменЛогин КАК ДоменЛогин,
		|	ТСП1.ДоменПользователя КАК ДоменПользователя,
		|	ТСП1.ЛогинПользователя КАК ЛогинПользователя
		|ПОМЕСТИТЬ ВТПользователи
		|ИЗ
		|	&ТСП1 КАК ТСП1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) КАК СдвоенныеЗаписиКоличество
		|ПОМЕСТИТЬ СдвоенныеЗаписи
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|
		|СГРУППИРОВАТЬ ПО
		|	ВТПользователи.ЛогинПользователя
		|
		|ИМЕЮЩИЕ
		|	КОЛИЧЕСТВО(ВТПользователи.ЛогинПользователя) > 1
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	ВТПользователи.ПолноеИмяПользователя КАК ПолноеИмяПользователя,
		|	ВТПользователи.ПользовательУникльныйИдентификатор КАК ПользовательУникльныйИдентификатор,
		|	ВТПользователи.ДоменЛогин КАК ДоменЛогин,
		|	ВТПользователи.ДоменПользователя КАК ДоменПользователя,
		|	ВТПользователи.ЛогинПользователя КАК ЛогинПользователя,
		|	СдвоенныеЗаписи.СдвоенныеЗаписиКоличество КАК СдвоенныеЗаписиКоличество,
		|	Пользователи.Ссылка КАК ПользовательСсылка
		|ИЗ
		|	ВТПользователи КАК ВТПользователи
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ СдвоенныеЗаписи КАК СдвоенныеЗаписи
		|		ПО ВТПользователи.ЛогинПользователя = СдвоенныеЗаписи.ЛогинПользователя
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи КАК Пользователи
		|		ПО ВТПользователи.ПользовательУникльныйИдентификатор = Пользователи.ИдентификаторПользователяИБ
		|ГДЕ
		|	НЕ Пользователи.ПометкаУдаления = ИСТИНА
		|
		|УПОРЯДОЧИТЬ ПО
		|	СдвоенныеЗаписиКоличество,
		|	ДоменЛогин"
		
		;
		Запрос.УстановитьПараметр("ТСП1",ТСП);
		Запрос.УстановитьПараметр("ЛогинКоличество",ЛогинКоличество1);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();                                
		Пока Выборка.Следующий() Цикл                                            //Выбираем результат запроса в цикле
			ПорядковыйНомер=ПорядковыйНомер+1;
			Строка=ТаблицаДействующихПользователей.Добавить(); 
			Строка.ПорядковыйНомер=ПорядковыйНомер;
			Строка.ПолноеИмяПользователя=Выборка.ПолноеИмяПользователя;                               
			Строка.ПользовательУникльныйИдентификатор =Выборка.ПользовательУникльныйИдентификатор;
			Строка.ДоменЛогин=Выборка.ДоменЛогин;
			Строка.ДоменПользователя =Выборка.ДоменПользователя ;
			Строка.ЛогинПользователя =Выборка.ЛогинПользователя ;
			Строка.ЛогинКоличество =Выборка.СдвоенныеЗаписиКоличество ;
			Строка.ПользовательСсылка =Выборка.ПользовательСсылка ;
		КонецЦикла;   
КонецПроцедуры
	

 

5

Скачать файлы

Наименование Файл Версия Размер
Повторяющиеся логины пользователей.:
.epf 10,56Kb
13.01.20
0
.epf 10,56Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. DJDUH 17 14.01.20 11:44 Сейчас в теме
А консоль 1С чем не подходит? или я не понял смысл этой обработки.
2. bryantsev.yury 18 14.01.20 12:22 Сейчас в теме
(1)Смысл этой обработки следующий:
В реальных базах идет большой оборот пользователей, возникают ситуации
когда появляются пользователи с одинаковыми логинами.
для выявления таких ситуаций была создана эта обработка, плюс дополнительная возможность просмотреть всех пользователей и просмотреть
действующих пользователей.
3. bryantsev.yury 18 14.01.20 12:34 Сейчас в теме
(1) Прошу уточнить какую консоль Вы имеете в виду.
Оставьте свое сообщение

См. также

Автоматическое создание ролей (объектов метаданных)
2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Роли и права

Обработка позволяет создать 2 роли на объекты метаданных (Чтение и Изменение).

2 стартмани

вчера в 09:20    378    kokorishvili    6       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Анализ ролей и прав доступа
1

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m) Роли и права

Показывает у каких пользователей активирована Роль или Права доступа.

1 стартмани

14.01.2020    449    t278    0       

Права на объект
158

Статья Программист Внешний отчет (ert,erf) v8 v8::Права 1cv8.cf Абонемент ($m) Роли и права

Если пользователю не хватает прав на объект, то на практике в 90 % случаев, недостающую роль можно найти через типовой регистр сведений Права ролей. Также с помощью дополнительного отчета или небольшого расширения можно ускорить описанный процесс.

1 стартмани

07.01.2020    6674    46    sapervodichka    12       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Анализ прав и ролей пользователей (обычные и управляемые формы)
8

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::УФ v8::Права 1cv8.cf Абонемент ($m) Роли и права

Отчет поможет в просмотре и анализе прав по ролям и пользователям по всем (или выбранным) объектам конфигурации.

1 стартмани

16.12.2019    956    4    Diana.dedov.91    0       

Перенос пользователей ИБ через COM-соединение (обычные и управляемые формы)
7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Необходимо скопировать несколько или всех пользователей в новую ИБ? Обработка (обычное и управляемое приложение) сможет это сделать!

1 стартмани

29.11.2019    1208    7    Diana.dedov.91    0       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Менеджер подключений к удаленным рабочим столам (RDP)
8

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) Роли и права

Менеджер подключений к удаленным рабочим столам для организации доступа сотрудникам, без передачи паролей для доступа.

2 стартмани

19.11.2019    1586    2    Shalnov    1       

Изменение запрета редактирования в дереве по группам пользователей
1

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::Права УПП1 Россия Абонемент ($m) Роли и права

Обработка позволяет менять дату запрета редактирования по пользователям в раскрывающемся списке группы пользователей. Тестировалась на УПП 1.3.126.2.

1 стартмани

19.11.2019    970    2    trest30    0       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Анализ прав пользователей
3

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 ERP2 Россия Абонемент ($m) Роли и права

Отображает права по ролям и пользователям на конкретный объект конфигурации.

1 стартмани

13.11.2019    1346    10    linder    9       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Анализ прав доступа
3

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::Права v8::СКД 1cv8.cf Абонемент ($m) Роли и права

Отчет по правам доступа, который позволяет выбрать объект метаданных и проанализировать, какие роли дают права на объект.

1 стартмани

08.11.2019    2001    9    Unk92    15       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Запуск внешних обработок по списку пользователей
0

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 БП3.0 Абонемент ($m) Роли и права

Создает командный файл для запуска пользователей по списку.

1 стартмани

07.11.2019    1451    Mari_Kuznetzova    0       

Блокировка учетных записей пользователей, кроме "Администратор"
0

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Роли и права

Обработка блокирует все учетные записи, кроме учетной записи именуемой - "Администратор".

3 стартмани

04.11.2019    1313    2    Alex1053669    0       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Установка даты запрета на любое число дней
5

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ11 Абонемент ($m) Администрирование данных 1С Роли и права

Примитивная обработка для установки даты запрета на произвольное число дней от текущей даты для всех пользователей

1 стартмани

29.10.2019    1731    2    Kutuzov    0       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Быстрое удаление ролей из профилей групп доступа.
7

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права Абонемент ($m) Роли и права

Обработка позволяет найти все профили групп доступа по роли, понять для каких групп доступа и пользователей доступна эта роль, удалить роль из выбранных профилей.

1 стартмани

23.10.2019    1681    1    igoSolo    0       

Копирование дополнительных прав, групп доступа между пользователями/группами [1С:Розница]
1

Инструменты и обработки no Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Абонемент ($m) Роли и права

Копирование, сравнение и редактирование дополнительных прав пользователей. Включение пользователя-приемника в те же группы доступа, в которых участвует пользователь-источник.

1 стартмани

21.10.2019    1799    1    RocKeR_13    0       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Расширение для установки запрета редактирования отдельных справочников и документов для Бухгалтерии 3.0
3

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права БП3.0 Россия БУ Абонемент ($m) Расширения Роли и права

Расширение позволяет устанавливать запрет на редактирование отдельного справочника или отдельного документа для отдельного пользователя базы данных. Написано для Бухгалтерии 3.0, проверено на релизе 3.0.72.70 и платформе 8.3.14.1854. Работает после применения ограничений профиля пользователя. Ограничивает даже права профиля с полными правами в открытом периоде.

1 стартмани

17.10.2019    1867    3    e-tixom    2       

RLS - дубли условий в запросах к СУБД
40

Статья Программист Конфигурация (md, cf) v8 v8::Права 1cv8.cf Абонемент ($m) Практика программирования Роли и права

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    4491    11    geron4    4       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Завершение работы пользователей
18

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Завершение работы пользователей с помощью подключения обработчика ожидания.

1 стартмани

02.10.2019    2862    3    user921814    6       

Сравнение прав пользователей
12

Отчеты и формы Системный администратор Внешняя обработка (ert,epf) v8 v8::Права 1cv8.cf Россия Windows Абонемент ($m) Роли и права

Иногда требуется понять, почему какому-то пользователю не доступны какие-либо объекты или действия, а "вручную" сравнивать довольно утомительное занятие.

1 стартмани

23.09.2019    2916    14    ivnik    3       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Оптимизация прав ролей
18

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8::УФ v8::Права 1cv8.cf Россия Windows Абонемент ($m) Производительность и оптимизация (HighLoad) Роли и права

Решение вопроса по неоптимальной настройке (избыточной) ролей, влияющей на производительность системы (потребление оперативной памяти). Алгоритм работы следующий: Выгрузка конфигурации в файлы - Обработка (изменение) файлов прав ролей - Загрузка измененных прав в конфигурацию. Проверено на платформе начиная с 8.3.12.

1 стартмани

09.09.2019    3653    3    toxilamer    11       

Расширение "Туманность" - помощник настройки профилей групп доступа. ERP 2.4.9+
8

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::Права ERP2 Абонемент ($m) Роли и права

Расширение позволяет настраивать профили групп доступа как комбинации из других профилей групп доступа.

1 стартмани

30.08.2019    1810    3    Brawler    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Расширение для БП 3. Роль "Покупки"
0

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 БУ Оптовая торговля Учет ТМЦ Абонемент ($m) Информационная безопасность

Дополнительная роль "Покупки" менеджеру по продажам для Бухгалтерии предприятия 3. Типовые права предусматривают только роль "Менеджер по продажам".

1 стартмани

23.08.2019    1937    4    Akuji    0       

Ограничение прав пользователя на изменение типов объектов конфигурации при помощи расширения
2

Инструменты и обработки Системный администратор Расширение (cfe) v8 v8::Права БП3.0 Абонемент ($m) Роли и права

Расширение позволяет ограничивать права пользователя на изменение типов объектов конфигурации при наличии прав, заданных профилями групп доступа.

1 стартмани

06.08.2019    1980    its_33    0